If you plan on making a large table with many rows and columns of information, we recommend you use “Table Documents”. The Table Documents creates a spreadsheet that can create dozens or thousands of rows of information. Use Table Documents to manage lists and “flat files” for all kinds of information like membership rosters, small databases, check lists, project data, expense logs, and more.

Keep&Share’s Table Documents are like any other spreadsheet  application without the formulas where you can quickly view, scroll, edit, and share tabular information.

The Import Table Document allows you to import a table document from an external .CSV file. For example, you can save your Excel file as a .CSV file and then use the Import Table command to bring the .CSV file in as a live, editable table in your Keep&Share document.

Table Documents can be entirely private to you, or you can set the Share Control on your table so others can view, or view and edit them.

You can easily publish a Table Document on a web page by setting the sharing to be “Public” and copy and paste a short “embed code”.

Table Document Organization

Tables consist of “rows” and “columns”, both of which contain “cells”. Think of rows as equivalent to a record in a database. Think of columns as equivalent to a field in a database record.

Every cell in a column is of the same type and is formatted according to the column type. Every column in your table can be one of these types:

  • Text: any kind of text such as name, address, comments.
  • Number: any kind of number.
  • Date: a date in any format you want, such as “Jan 25, 2012” or “01/25/12”.
  • Choice: a drop down list with values you specify such as “orange, green, blue, red, black”, if for instance, you wanted that column to only allow those 5 colors.
  • Check Box: the column displays a check box.
  • Unique Number: each table will be numbered in ascending order beginning with “1”.

Three main working screens in Table Documents

When you are working with Table documents, there are three main screens to accomplish your tasks:

  • View Table: click on a table document and it is displayed on screen for you to view. You can scroll through the table, sort the table by clicking on column headers, print and export the table. Learn more about viewing Table Documents.
  • Edit Table Contents: click the blue “Edit” command next to a table to enter edit mode, where you can add and delete rows in your table and edit the contents of each row. This is how you add new rows to your table or edit an existing row (e.g., to edit someone's phone number to have a new value). Learn more about editing table contents.
  • Edit Table Structure: once you are editing a table, click the “Edit Table Structure” button to edit the structure of your table, such as define the name, number and type of columns in your table. You can use this screen at any time to add or delete columns. This screen also controls the colors used to display your table. Learn more about editing table structure.

Learn more about getting started with Table Documents.